La première chose que vous remarquez à propos du code lorsque vous l’insérez dans votre programme est que la fin de l’instruction *Anweisung est manquant.

De même, votre ami a une faute d’orthographe mineure, car la deuxième répétition se termine par *wiedrehole au lieu *wiederhole

Voici comment le programme fonctionne maintenant et vous pouvez le tester, mais malheureusement, il reste toujours avec le message d’erreur suivant:

Fehler
[Abbruch](Zeile14) Vor Karol liegen keine Ziegel mehr zum Aufheben

Cela est dû au fait que sur la première pile, 5 fois 2 briques (soit un total de 10) sont soulevées, mais seulement 9 se trouvent là. Vous devez également vérifier avant le dernier ascenseur s’il reste une brique.

Dans l’ensemble, le code ressemble alors à ceci:

Anweisung Sprung
  wiederhole 9 mal
    Hinlegen
  *wiederhole
  Schritt
  wiederhole 8 mal
    Hinlegen
  *wiederhole
  wiederhole 9 mal
    Schritt
    LinksDrehen
    LinksDrehen
    Aufheben
  wenn IstZiegel dann
    Aufheben
  *wenn
  *wiederhole
*Anweisung

.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *